Trouble logging in
Incident Report for Ecanvasser
Resolved
This incident has been resolved.
Posted Sep 27, 2022 - 01:17 UTC
Update
We are aware of the current issue, working on it urgently and we deeply apologize for this occurrence. It can be expected for the platform to be impacted for up to hours potentially. Please know our development team is working hard to get the matter resolved, and we will share updates as soon as we can.
Posted Sep 26, 2022 - 22:15 UTC
Update
We are continuing to investigate this issue.
Posted Sep 26, 2022 - 21:57 UTC
Update
We are continuing to investigate this issue.
Posted Sep 26, 2022 - 21:24 UTC
Investigating
US-based users may be experiencing trouble when logging in to the Ecanvsser Dashabord and Mobile Apps.
Our engineering team is currently investigating the issue further.

We will send an additional update as soon as we can.
Posted Sep 26, 2022 - 21:23 UTC
This incident affected: Ecanvasser Dashboard, Ecanvasser Walk - Mobile App, and Ecanvasser Go - Mobile App.