Identified service disruption
Incident Report for Ecanvasser
Resolved
This incident has been resolved.
Posted Nov 29, 2021 - 11:23 UTC
Identified
We’ve determined that some Users are unable to log into Apps or access all features on dashboard

US and EU users may be affected.

We’re working to resolve all issues .

Next update in 12:00 GMT.
Posted Nov 29, 2021 - 11:12 UTC
This incident affected: Ecanvasser Dashboard, Ecanvasser Walk - Mobile App, and Ecanvasser Go - Mobile App.