Customers may have difficulty accessing the Web App
Incident Report for Ecanvasser
Resolved
This incident has been resolved.
Posted Apr 21, 2021 - 11:07 UTC
Monitoring
We have resolved this issue and will continue to monitor
Posted Apr 21, 2021 - 08:07 UTC
Investigating
We are currently investigating an incident impacting the web app dashboard and will update this incident with more details as they are available
Posted Apr 21, 2021 - 07:00 UTC
This incident affected: Ecanvasser Dashboard.